My AVID Access

Incident Report for AVID Center

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 17:59 PDT

Update

Microsoft has indicated that the issue is nearly resolved and our testing confirms services have been restored. We will continue to monitor the situation until fully resolved.
Posted Oct 29, 2025 - 17:11 PDT

Monitoring

Microsoft has recovery efforts underway; we're seeing improvements but still intermittent access to the platform. We'll continue to monitor this situation and update as progress happens. For real time updates from Microsoft please reference: https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 12:54 PDT

Identified

We are actively monitoring an outage that Microsoft is experiencing that is impacting these services. You can monitor the status directly at: https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 09:30 PDT

Investigating

We are currently investigating this issue.
Posted Oct 29, 2025 - 09:24 PDT
This incident affected: MyAVID.