Canvas Issues

Incident Report for AVID Center

Resolved

This is now resolved
Posted Nov 04, 2025 - 11:52 PST

Monitoring

Canvas has deployed fixes and services appear to be improving. Live updates from Canvas can be seen here: https://status.instructure.com/.
Posted Nov 04, 2025 - 11:20 PST

Identified

We are actively monitoring the issues impacting Canvas, real time updates from Canvas can be found at: https://status.instructure.com/.
Posted Nov 04, 2025 - 10:52 PST

Investigating

We are investigating reports of issues accessing Canvas
Posted Nov 04, 2025 - 09:10 PST
This incident affected: eLearning Service (Canvas).